Back to overview
Resolved
Fan investigation continues
Jul 8, 2026 at 5:08pm UTC
–
Jul 8, 2026 at 5:12pm UTC
Affected services
iambest.net
Resolved
Jul 8, 2026 at 5:12pm UTC
Maintenance ended
Affected services
Created
Jul 8, 2026 at 5:08pm UTC
We went offline to safely remove the fan temporarily. We'll be back without a fan for now but as well said the performance should be the same. We apologize for the inconvenience this may cause!
Affected services