Back to overview
Resolved
Downtime at random times
Jun 27, 2026 at 12:22am UTC
Affected services
iambest.net
Resolved
Jun 27, 2026 at 12:22am UTC
We are aware of an issue with our Internet causing it do go down at unexpected times. We are still investigating this issue and keep you updated. We know that the downtime appears to happen once every 2 days for around 3 - 17 minutes. We apologize for the inconvenience this may cause.
Affected services