Back to overview
Resolved
Website not available
Jun 22, 2026 at 6:08pm UTC
Affected services
iambest.net
Resolved
Jun 22, 2026 at 6:14pm UTC
The website wasn't available due to a power outage (again) and recovered automatically. ;-; We apologize for the inconvenience this may have caused and we very are disappointed from our electricity provider and will be finding solutions in the future.
Affected services
Created
Jun 22, 2026 at 6:08pm UTC
The website isn't available due to a power outage and will recover automatically. We apologize for the inconvenience this may cause.
Affected services