Back to overview
Resolved
Website not available
Jun 14, 2026 at 12:38pm UTC
Affected services
iambest.net
Resolved
Jun 14, 2026 at 12:44pm UTC
The website wasn't available due to a power outage (again) and recovered automatically. ;-; We apologize for the inconvenience this may have caused and we are disappointed from our electricity provider.
Affected services
Created
Jun 14, 2026 at 12:38pm UTC
The website isn't available due to a power outage and will recover automatically. We apologize for the inconvenience this may cause.
Affected services