Back to overview
Resolved

Website not available

Jun 1, 2026 at 3:32pm UTC
Affected services
iambest.net

Resolved
Jun 13, 2026 at 7:53pm UTC

The website wasn't available due to a power outage and recovered automatically. ;-; We apologize for the inconvenience this may have caused.

Updated
Jun 13, 2026 at 7:51pm UTC

The website isn't available due to a power outage and will recover automatically. We apologize for the inconvenience this may cause.

Updated
Jun 1, 2026 at 3:35pm UTC

The website wasn't available due to a power outage and recovered automatically. ;-; We apologize for the inconvenience this may have caused.

Created
Jun 1, 2026 at 3:32pm UTC

The website wasn't available due to a power outage and will recover automatically. We apologize for the inconvenience this may cause.